Pues si a la movida que hubo semanas atrás entre el trío IBM - Red Hat Entreprise Linux - Centos no hubiera sido suficiente, ahora se suma la que la The Qt Company propietaria del framework Qt a anunciado: La versión 5.15 LTS sera solo para clientes comerciales.

Y es que por si no te haz enterado, hace un año The Qt Company anuncio que restringiría los lanzamientos de las versiones LTS del framework a los clientes comerciales, cuya anuncio no fue muy bien recibido entre los entusiastas del software libre, ya que hay varios proyectos que usan estas librerías y framework para su desarrollo.

Pues ya se a empezado a materializar las intenciones de la compañía en la Qt 5.15, cuyas ramas públicas de la versión Open Source han sido cerradas excepto WebEngine y el obsoleto Qt Script, ya que ambos componentes tiene partes de terceros que estan bajo la licencia LGPL.

Eso implica que los que usan la version 5.15 Open Source de Qt, ya no recibiran mas parches, lo que supone un riesgo de seguridad aparte de los propios fallos de software. Para los desarrolladores, tambien hay implicaciones, ya que los perjudica en dos frentes: Primero, los que trabajan en los parches para la versión Open Source, verán que ya no pueden acceder al código. Segundo, la versión 6 de Qt se ve bastante prometedora por las novedades que traerá, pero como la misma The Qt company a reconocido, aun no esta lista para sustituir a la rama 5.15 actualmente en desarrollo.

De otra parte, se a propuesto que la versión Open Source 5.15 sea mantenida por la comunidad sin la intervención de The Qt company, sin embargo aun no ha habido respuesta de parte de la compañía, por lo que se a especulado acerca de una bifurcación.

Y para rematar la faena, The Qt Company quiere cerrar aun mas la presencia de las versiones Open Source del framework, haciendo que estas versiones tenga soporte solo de un año para los clientes comerciales.